ALMANAC Interface Guide
Working with an Existing ALMANAC Project:

Opening the Project:

1. Start the ALMANAC Interface

2. Choose the ALMANAC Project Setup -> Open Project menu item

3. The following dialog will open. Click the folder to browse to your project. 
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4. Choose a project and click OK. Your map will zoom to the extent of the current project.
This will be a field location that has been specified for the current project. Cr, if you have
not yet specified a field location, it will zoom to the extent of the county that the project 3
.

was defined for.
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4. Choose a project and click OK, then OK again. 
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5. Your map will zoom to the extent of the current project. This will be a field location that has been specified for the current project. Or, if you have not yet specified a field location, it will zoom to the extent of the county that the project was defined for. 
Field Location and Soil for the Current Project:
1. Choose the ALMANAC Inputs -> Define Field Soil menu item

2. The Define Field and Soil dialog will open. If the field location and soil have already been defined for the project, the dialog will look like this:
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3. This shows that the SSURGO dataset shapefile and tabular folder have already been specified. You should never need to go back and re-specify these files. That is why the controls are grayed out.
4. The second tab, “Set Field Location”, looks as follows: 
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5. This shows that the soil for the current field location is “Houston Black clay, 0 to 1 percent slopes” and the location is 31.1284,-97.4044. Note: Since the field location and soil are already defined, you can click “Cancel” and move onto the next step. 

6. If you want to change your field location, you can click on “Pick Field on Map”. Your cursor will become a pointing finger, and you can choose a new location on the map.
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7. To assist with choosing a point, you can also check the Label Soils box in the Map Control menu and zoom in to see where your soils are located spacially. 
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8. Alternatively, you can choose “Pick field from Lat/Lon” and enter your latitude and longitude in decimal degrees, then hit OK. 
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9. After using either method, new field location will be drawn. Pop-up windows will alert you that you were successful and to proceed to the weather definition. 
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10. If you reopened “Set Field Location”, you could see the name of the soil and coordinates were updated. Click “Cancel” to leave the field location/soil definition dialog.
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11. Note: You will have the opportunity to change the soil for the current ALMANAC run (by picking from a list of soils in the county) later on. 
Starting a New ALMANAC Project:

Creating a New Project:

1. Start the ALMANAC Interface

2. Choose the ALAMANAC Project Setup -> New Project menu item

3. The following dialog will open.
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4. Specify the following:

a. ALMANAC Project Folder: This can be any name and any path on your local computer. However, since an ALMANAC project is based on a county (due to its linkage with SSURGO soils), the county name is an appropriate project name. Use the browse button (folder icon) to select your folder path. It is easy to find your projects later if you place them all in the ALMANAC -> ALMANAC Projects folder first, then you can organize them how you wish. In the example, they are then organized by state, then project name. Click the Make New Folder button to create your project’s folder, give it a name, then click OK. 
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b. State: The state for your project

c. County: The county for your project

d. Initial Crop Growing: The default crop growing for your project. This can be changed later on. 
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5. After specifying all these inputs, click OK. A new project is created and your map will zoom to the extent of the county you selected.
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Field Location and Soil for the Current Project:
1. Choose the ALMANAC Inputs -> Define Field Soil menu item

2. The Define Field and Soil dialog will open.  You must first specify the location of the SSURGO shapefile and the location of the SSURGO tabular data.
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3. Use the file browse button to find the SSURGO soil folder of the county for this project. The folder you choose for the SSURGO spatial folder will be located in the unzipped SSURGO file you downloaded from NRCS Web Soil Survey and will be named “spatial”. Select the “spatial” folder, then click OK. For more instructions on how to download soils read “HowtoSoils” document. 
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4. Use the file browse button to select the SSURGO tabular folder for the county you have selected for your project, then click OK. 
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5. Once you have specified the locations of your files, click “Load SSURGO Data”. Your SURRGO soils polygons will be added to the map
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6. You will then be automatically placed on the “Set Field Location” tab of the dialog. Here, you will define your field location and the soils name will be extracted from the GIS dataset.
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7. To choose your field location, you can click on “Pick Field Location on Map”.  Your cursor will become a pointing finger, and you can choose a new location by clicking on the map.
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8. To assist with choosing a point, you can also check the Label Soils box in the Map Control menu and zoom in to see where your soils are located spacially. 
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9. Alternatively, you can choose “Pick field from Lat/Lon” and enter your latitude and longitude in decimal degrees, then hit OK. 
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10. After using either method, new field location will be drawn. Pop-up windows will alert you that you were successful and to proceed to the weather definition. 
Pick from map 



Pick from map with label soils selected
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Pick from Lat/Lon
[image: image26.png](W] almanachowtoB.doc [Compatibility Mode] - Microsoft Word r—
i

ALMANAC Project Setup ~ ALMANAC Inputs ~ ALMANAC Simulation N A A Find -
’ " s o S |l AcBbCcL  AaBbCel AcBbCeD. | AcBBCCl| AaBbCel AaBbCel AaBb( AcBbCcl 4aBbCcl daBiCel AaBbCa AaBbCe A e
> Aabbce - 2 Replace
| jeading jeading jeading lormal rong ubtitle 3 lo Spaci. ubtle Em. Intense. uote. Intense. ubtle . Change
—r Heading2 THeading3 THeading4 | TNomal | Strong  Subtit THe  TNoSpac. Subtiefm.. IntenseE. Quote IntenseQ.. SubteRer.. o] ChanOE | o
| zoomou || Stytes | eatng |
o Pan s . 3 . s ; : 7 1 &
[ Label Courties
Label Sols

xampl g]

IC:\Pmiecls\ALMANAC\Data\Dalabases\Exampl E

Load SSURGO Data

=
“o w4










11. If you reopened “Set Field Location”, you could see the name of the soil and coordinates were updated. Click “Cancel” to leave the field location/soil definition dialog. This shows that the soil for the current field location is “Houston Black clay, 0 to 1 percent slopes”.
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12. Note: You will have the opportunity to change the soil for the current ALMANAC run (by picking from a list of soils in the county) later on. 
Common Steps for New and Exiting Projects:

Weather Definition for the Current Project:
1. Note: If the ALMANAC Inputs ->Edit ALMANAC Inputs menu item is not grayed out, then your weather stations have already been defined, and they do not need to be defined again. You would ONLY want to redefine the weather stations if you have just chosen a new field location for your project.
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2. If weather stations do need to be defined, then choose the ALMANAC Inputs -> Define Weather Stations menu item
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3. To use weather generator stations for from the US database and no observed weather data, simply click “Load Weather Data”. The closest weather station to your specified field location will be identified. Close the successful import notification & weather window.
4. If observed weather is being used, read “NOAAfiles” to learn the proper weather file format. After your file is formatted, then select which inputs will be observed (e.g., precip, temp), choose the ALMANAC formatted weather file location, then click “Load Weather Data”. Close the successful import notification & weather window. 
Load Weather Data, Nearest Station Added

Load Weather Data, Observed Weather Uploaded
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Editing ALMANAC Scenarios:
1. Choose the ALMANAC Inputs->Edit ALMANAC Inputs-> Scenario Definition menu item. This will open a dialog that lets you edit any of the ALMANAC runs associated with the current project.
Default Scenario Window



  Scenario Window After Adding New Scenarios
[image: image33.png]almanachowtoB.doc [Compatibility Mode] - Microsoft Word

T ———

— [e[@] =
|[| ARy (CTRErs AR AGBLCCL AaBbCel ABbCED: AsBbCal Aambcer AaBbC AdBbCet AasiCer amscer AcgbCa Aasbce asmaca | A BT
Paf ;’G‘"’" THeading2 1 Heading3 1 Heading4 Stong  subtitie Tle  TNoSpaci. SubtleEm.. IntenscE.. Quote  IntenseQ.. SubtleRef..  Change E‘S“‘v
camin B i s
] oo e cang
o] Pan : . : : s z < Z 1 B
i AANA e = 165D: [0 ]
St ot st | S Coparr g | e |
Scenario Name: nputs igtied | ET: |1 Edit Run
i SCENARO D 1 Send e
e
Corment 1. EEERENE Cancel Edits |
Comment 2: Temple New_Default
) rovr: - 8 Save Edits
e o o |
o 1 o 0 i
o 3 Gs0: 0 Exit |
] o, 0 o
oz 30 aant
T | [ osee
el | ey
[
]
I Z\q
_p-edit, then-click-“Edit-Run”.-You-are'now"in-edit-
i mode. 1
3.~ Once you-are‘in-edit-mode, you-can-edit-any-of the run-parameters, -including- the soil-for- 5
] the-current-run-and-the'management-schedule for the-current-run. 1
4.+ On-theSoil-Component-tab, you-can-click the-“Select-New”-button-near-the- “MUNAME” -
g text-box-to-select-anew-soil-forthe run-from-arlist-of-soils-in-the-county . 5

Page 17 0120 | Woras 1325 | 5 |




 [image: image34.png]w]

almanachowtoB.doc [Compatibility Mode] - Microsoft Word

[ rove | imset  Pagelajout  References  Mailings  Review  View

B

t s hrmav
ElegaGarmnd B - 11 - AT A 20 (9] sapbcer ARBBOGI ABbCCL AaBbCel AcBbCen AaBbCA AaBbCcl AaBb( AaBbCcl 4aB5CcL AaBbCcl AaBbCa AaBbCe AABBCCI /A

B Copy 8. Replace
P‘“‘P - 3 - mphasis jeading jeading jeading jeading rong ubtitle 3 lo Spaci. ubtle Em. Intense. uote. Intense. ubtle | Change
Fromstpanter B L U ke X X 22 Emphasis T Heading1 THeading2 T Heading3 T Heading. Strong - Subtit Tle  TNoSpac.. Subllefm.. Inensef.  Quote InfenseQu. SubtleRefn o ChOnge Tl
Clipboard o Font o Paragraph o Styles. = | Editing
[c] T T T — T : 7 : £l : ) : B : © 7 ] ]

- Choose the' ALMANAC - Inputs->Edit- ALMANAC - Inputs->-Scenario- Definition- menu-item. -
.mnmmm_ ro fthe' ALMANAC ‘runs-associated with-the-

‘Scenario Ifomation | Ste Infomation | Sol Componert | Managemert

Inpuis ighighted
" ‘Soenario Name: 5
SCENARIO ID: 1 ‘specil user.
Temple Com considestr
Energy Sorghum Comment 1: Temple New_Defaut

i Neve: 10 D 3
R s Nan:
w1 N
ow: 1 6sD: 0
. NPD: 0 o
coz 30 Gzt

Parameter Detal

2.-Toedit-arun, select-the run-you-wishto-edit, then-click-“Edit-Scenario”.- You-are now-in-

edit-mode. If-you-don’t-know-what the-abbreviations-mean, - doubleclick the parameter.-1





2. To edit a run, select the run you wish to edit, then click “Edit Scenario”. You are now in edit mode. If you don’t know what the abbreviations mean, double click the parameter. 
3. Once you are in edit mode, you can edit any of the run parameters, including the soil for the current run and the management schedule for the current run.

4. The Scenario Information tab lets you specify how long the simulation will run and what form the output will apear. 
5. The Site Information tab contains field charateristics and weather inputs. For example, TEMPLE weather station is selected by the generator, observed weather is blank. 
[image: image35.png]almanachowtoB.doc [Compatibility Mode] - Microsoft Word

— [=[@] =
i et EEALMANAC rput= P ALMANAC Semudofion AGBbCCL AaBbCcl  AcBbCD. AaBbCl AaBbCcI AaBb( AoBbCcl AaBbCcl 4aBbCeL AcBbCel AaBbCe AMBECC M ?a:::n;
somin o | 1y see
| S e T
o] Pan . E : : : : 0 < Z 1 B
it ALVANAC mhsslllick the “Select:New” -button near-the-“MUNAME” -
g ) o
p— eraes from-arlist-of soils:in-the county .«
| o 1 oz 7 o @ o 00 T
=
on 1B o 0 o . S ; ;
s o o o 08 P MUSYM: [RaB  COMPNAME: [Rader
ww s o e 7 @ o
i . e e s B
- o3 TsLa: [0
Weather Inputs
5 851 e 1806 T 8 BTA 0 1) WTMN: Ig
ok sw: 05 =T on: B
3 wew: 17526 WM Se: X wNo: 4777 WND Site: TX DS: IU RFTT: IO
Wew s, [Sooaton]  WNDSaor: [Soiew] G Woobr St
TaE TeveLe
i BD: [14 u: [oo7e
P——
M e e
_ N: [07352941 cac: fo
i - limo3: Jo 4p: [o
; T P [o sc: [io0s
i AT: o wp: [0
=
1
] 5.~ Choose-arsoil from-the list-and-click-“OK” .-
Choose Fr: t x|
County SOils .
N _,—,—e— e —_—_e—e—_———— f





6. On the Soil Component tab, you can click “Select New” button near the “MUNAME” text box to select a new soil for the run from a list of soils in the county.
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7. Choose a soil from the list, and click “OK”.
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8. Note: The new selected soil will be assigned ONLY to the selected run being run, not all the runs in the current project. This allows different soils to be simulated for different runs within the same project.
9. This tab also allows you to change soil characteristics in Component Attributes, and make changes by layer in the Layer Attributes section.
10. On the Management tab, you can change the management schedule being assigned to the current run the way you did for changing the soil. (Select New, Choose From List, OK.) 
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10. On the Management tab, you can change the management schedule being assigned to

8 e v sy = e soil. (Select New, Choose From List, OK.)

‘Soenario Ifomation | Ste Infomation | Soi Component | Management

Seneie. SHEH Pkl Cesrpon: Gone et vt forALAHO SWITCHGASS e
Management Seings cesenl
o 1 o -
R D . 9
"R o AN 0
"o Aew o -
o w0 E|
w0 w0
o o fc
R oAT- 0
[ FosF. 0
R 0 l
E— o ]

h choose from are the ones found in your

|any tab to be saved.

Editing ALMANAC Management Schedule : 4
1. Choose the ALMANAC Inputs->Edit ALMANAC Inputs-> Management Schedules menu :
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11. The list of management schedules that you can choose from are the ones found in your management schedules database.
12. You must click “Save Edits” for your edits from any tab to be saved.
Editing ALMANAC Management Schedule:
1. Choose the ALMANAC Inputs->Edit ALMANAC Inputs-> Management Schedules menu item. This will open a dialog that lets you create, edit, or delete any of the ALMANAC management schedules in the ALMANAC database.
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2. When adding a new Management Schedule, select an existing schedule that is similar to what you want, then click Add. This will copy the existing schedule format into the new one, like a template. Enter the new management schedule’s name and a short description.
3. To edit a schedule, select it from the list, click Edit. Now you can use the buttons below the Management Operations window which allow you to Add Operation, Edit Operation, Delete Operation, Add Year, or Delete Year. 
Edit





Operation buttons now available
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a. To add an operation, select an operation in the year you wish to add the new operation, click Add Operation, choose what type of operation you want from the Choose Operation window, OK. In some cases the operation requires a plant species, so choose it from the next pop-up window. You are then taken back to the Edit ALMANAC Management Schedules window Operation Parameters box where you can change Operation Parameters for the new operation (like date operation occurs). Once you’ve completed the operation in Operation Parameters click OK.
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b. To edit an operation, select it in the Management Operation window, click Edit Operation. Now the Operation Parameters window is activated. Make your changes and hit OK.

c. You can Add Year or Delete Year using the buttons provided. The final year listed will be the one deleted, added years also appear at the end of your simulation (meaning you cannot add a year between 1st and 2nd, it will appear at 3rd year). If year 1 and year 2 have different managements, select an operation in the year with the management most similar to the one you desire for year 3 before clicking the Add Year button – this will save you time in creating the 3rd year’s management schedule. 
4. You must click “Save Edits” for your edits to be saved. Always press Save Edits when changes have been made to a schedule, this is still true when creating a new schedule.   [image: image47.png]L=t X
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Running ALMANAC Model:
1. Choose the ALAMANC Simulation->Run ALMANAC Model menu item. The following dialog will appear.
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2. From the table, choose the run you wish to execute. Then click, “Update Input Files”. 

3. Finally, click “Run ALMANAC”.
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4. Once it completes, close the dialog, then choose the ALMANAC Simulation->ALMANAC Output menu item. This opens the following dialog:
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5. Click the “Open ALMANAC Output File” button to check the output file.

Reading ALMANAC Output:
1. The output can be a bit overwhelming at first. The first part is showing what was run, plant parameters, soil, weather, management. Every year will begin by listing the management, then the details, followed by a summary. At the end of the output is the simulation averages. For details on what the output abbreviations mean, read “ALMANAC Output Abbreviation Key”.
